В iOS 14.1 и ниже есть баг, дающий надежду на джейлбрейк

Сегодня Apple публично выпустила iOS 14.2. Многие обновились до новой версии ради новых эмодзи, обоев и новых функций. Кроме того, это обновление улучшило безопасность системы.

iPhone-Matrix-Code-Exploit-768×485

Улучшения безопасности системы – это хорошо для обычных пользователей. Однако любители джейлбрейка так не считают, поскольку именно за счёт уязвимостей и возможен джейлбрейк. Именно поэтому разработчики джейлбрейк-инструментов всегда советуют оставаться на как можно более старой версии системы. Это повышает ваши шансы установить джейлбрейк в будущем.

Это правило касается и выхода iOS 14.2. Новая версия исправила аж 24 бага, многие из которых могли помочь взлому системы. Больше всего внимания привлёк баг «CVE-2020-27905».

Simo-Kernel-Bug-iOS-14.1-464×500

Пользователь (@_simo36), обнаруживший баг, поделился доказательством того, что с помощью бага получается взломать систему.

Simo-Tweet-on-Kernel-Bug-for-iOS-14.1-768×1091

В iOS 14.2 этой уязвимости больше нет, но в iOS 14.1 и ниже – есть. Пока что это только баг, а не полноценный эксплойт. На его основе можно создать эксплойт, что и намеревается сделать пользователь, обнаруживший баг.

Что это значит для джейлбрейк-сообщества? Ничего… пока что! В теории джейлбрейк-инструменты Odyssey и/или unc0ver могут начать поддерживать версии до iOS 14.1. Если на основе бага получится создать эксплойт, это многое изменит. Особенно если его выпустят публично.

Нет никаких гарантий, что это произойдёт. Однако надежда есть. Мы советуем не обновляться с iOS 14.0-14.1 до iOS и iPadOS 14.2, если в будущем вы хотели бы установить джейлбрейк.

Узнать о баге больше вы можете на странице GitHub.

Оцените пост
[всего: 0 рейтинг: 0]

Добавить комментарий